Man sitting on a couch looking on his iPad for Philips HearLink compatibility

Compatibility of Philips HearLink hearing aids and apps

Philips HearLink behind-the-ear hearing aids use dual-core 2.4 GHz Bluetooth® Low Energy technology to connect Philips HearLink to virtually every smart device.

Get information about compatibility of smartphones and other devices with the Philips HearLink hearing aids, Philips HearLink app, Philips HearLink Connect app and the Philips AudioClip.

Philips HearLink family BTE with mfi badge

Philips HearLink hearing aid compatibility

Philips HearLink behind-the-ear styles are Made for iPhone®, iPad Pro®, iPad Air®, iPad®, iPad mini®, and iPod touch® hearing aids.

You can directly connect your hearing aids to your smartphone or other device without an accessory, so you can stream audio, answer phone calls, adjust settings, and more.

Made for iPhone

Philips HearLink hearing aids in the styles BTE PP, miniRITE, miniRITE T and miniRITE T R are compatible with:

iPad (5th gen), iPad (6th gen), iPad (7th gen), iPad Air (3rd gen), iPad Air 2, iPad mini (5th gen), iPad mini 4, iPad Pro 10.5", iPad Pro 11" (1st gen), iPad Pro 12.9" (1st gen), iPad Pro 12.9" (2nd gen), iPad Pro 12.9" (3rd gen), iPad Pro 12.9" (4th gen), iPad Pro 9.7", iPhone 11, iPhone 11 Pro, iPhone 11 Pro Max, iPhone 6S, iPhone 6S Plus, iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8 Plus, iPhone SE (1st gen), iPhone SE (2020), iPhone X, iPhone XR, iPhone XS, iPhone XS Max, iPod touch (7th gen), iPhone 12, iPhone 12 Pro, iPhone 12 mini, iPhone 12 Pro Max.

For all hearing aids we recommend iOS 13 or later.

We recommend you to always update your device to the latest version of the operating system.

Philips HearLink app compatibility

The Philips HearLink app can be used with wireless Philips HearLink hearing aids.

See the list below to identify the mobile devices which are tested to be compatible with the Philips HearLink app. If your device is not listed, it is still possible for it to be compatible with the Philips HearLink app.

We recommend you to always update your device to the latest version of the operating system.

Compatible iOS devices (13.0 or later)

Compatible Android devices

The app is compatible with Android 8.0 and later and we generally recommend using the latest available version of Android.

For best performance we recommend the following devices:

Philips AudioClip compatibility

See the list below to identify the devices which are tested to be compatible with the Philips AudioClip.

If your device is not listed, it is possible for it to be compatible with Philips AudioClip if it works on Bluetooth 2.1 or later.

Apple, the Apple logo, iPhone, iPad, iPod touch, and Apple Watch are trademarks of Apple Inc., registered in the U.S. and other countries. App Store is a service mark of Apple Inc.

Android, Google Play, and the Google Play logo are trademarks of Google LLC.

Hi there
It seems you are visiting this website from the United States. Would you like to navigate to the United States' website instead?